How to tell Linq which Database Version to use

i am using sql server 2005 and I think Linq generating queries for a different database version. I got the query string that linq was producing and pasted the linq directly in SQL Server Management studio and it failed with many errors. But the query works well if Linq is used. Any ideas what could be going on. If linq needs to know what database version to use how do I do that?

  • How to handle import of file with UTF-8 encoding, codepage = 65001, into SQL server
  • Visual Studio 2005 doesn't support Sql Server 2008
  • nth day to nth month in SQL Server
  • Sql server 2005 knowing new record is inserted
  • Where is SQL Profiler in my SQL Server 2008?
  • What tools are out there for profiling stored procedures in SQL server other than the MS profiler?
  • Update button keeps updating on click of Refresh in IE
  • When should I use an INNER -LOOP- JOIN instead of an INNER JOIN
  • How to concat many rows into one string in SQL Server 2008?
  • SQL Server 2008 SSMS won't remember password
  • How to parse a string and create several columns from it?
  • In-Out Parameter for SqlCommand
  • One Solution collect form web for “How to tell Linq which Database Version to use”

    LINQ will create a parameterized query. You won’t be able to directly copy the SQL into SSMS without adding definitions (and assigning values to) the parameters.

    MS SQL Server is a Microsoft SQL Database product, include sql server standard, sql server management studio, sql server express and so on.